您的位置 » 首页 » web技术 » Let’s encrypt证书自动续期错误排除

Let’s encrypt证书自动续期错误排除

发表于9月前 | 作者: Kar Chan | 分类: web技术 | 破蛋日:2017年03月07日 | 流行热度: 576 views°

众所周知,Let encrypt的免费证书非常好用,唯一的缺点就是证书只有三个月的有效期,不过好在它支持免费续期。

不过这也不是什么难事,直接写个脚本做个定时任务更新一下就好了,之前更新一直没有问题,但今天登录邮件收到证书要到期的提醒。

于是登录主机,发现自动更新的JOB报错了,报错如下:

初看报错,应该是由于缺少相应的权限导致,再查看nginx日志,果然有403的报错。

应该是nginx的配置问题导致的,检查nginx配置发现如下配置

原来在之前配置安全的时候将隐藏目录的访问权限全部deny了,在该语句上面加上如下语句并重启nginx解决。

 

文本标签:
本文地址:https://www.kar-chan.com/?p=7471
除非注明,本站所有文章皆为原创,转载请以链接形式标明本文地址

马上分享给你的朋友吧~

发表评论

你的大名(必填)

你的邮箱(必填)

你的网站(选填)

评论内容(必填)